geen toegang meer tot gepinde sites

Hier vind je nieuws over updates met betrekking tot de website. Ook kun je hier suggesties plaatsen.
Eller
Berichten: 9
Lid geworden op: 1 Oktober 2013, 9:59
Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0

geen toegang meer tot gepinde sites

Berichtdoor Eller » 1 Oktober 2013, 21:00

Firefox staat, als standaardbrowser, onder in de taakbalk van W7/32 Ultimate.
Instelling: automatische updates.
Bij een recente update werkt geen van de gepinde sites nog.
Ik heb met Revo Uninstaller FFX gedeinstalleerd, een verse opgehaald (versie 24.0) en geinstalleerd, maar de foutmelding blijft

Is er een fix om dit te herstellen?

Afbeelding

Gebruikersavatar
Frederik
Moderator
Berichten: 4273
Lid geworden op: 1 Juli 2004, 16:16
Locatie: Vriescheloo
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Re: geen toegang meer tot gepinde sites

Berichtdoor Frederik » 2 Oktober 2013, 11:06

Dit lijkt me geen fout van Firefox maar een probleem binnen Windows.
Kijk eens bij het Configuratiescherm > Programma's > een bestandstype altijd met een specifiek programma openen > of overal staat aangegeven dat met een htm/html met Firefox moet worden geopend.

Eller
Berichten: 9
Lid geworden op: 1 Oktober 2013, 9:59
Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0

Re: geen toegang meer tot gepinde sites

Berichtdoor Eller » 2 Oktober 2013, 16:08

begrijpelijke reactie, Frederik, maar daar had ik al gekeken. Ik heb ook een stap meer gezet dan Windows zelf doet.
Die koppelt .url simpelweg aan de Internetbrowser (standaard) Ik koppelde hem specifiek aan FFox, maar ook dan gaat het fout.
Ik had de fout eerder en kon toen via een (ghost) backup terug naar vóór die update.
Daardoor kon ik nu nagaan dat het onmiddellijk ná een ffx-update optrad! Maar verklaren kan ik het ook niet.
Ik zou nog eens in het register kunnen zoeken naar FirefoxURL...
Ik hoopt eigenlijk op herkenning hier op het FF-forum.

Gebruikersavatar
Frederik
Moderator
Berichten: 4273
Lid geworden op: 1 Juli 2004, 16:16
Locatie: Vriescheloo
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Re: geen toegang meer tot gepinde sites

Berichtdoor Frederik » 2 Oktober 2013, 17:59

Wat ook nog kan is IE instellen als standaard browser en dan vervolgens FF weer instellen als standaard browser: dan wordt het protocol opnieuw vastgelegd.

Er zijn nog meer alternatieve oplossingen (waaronder register aanpassingen), maar die zijn niet in het Nederlands beschikbaar:
https://support.mozilla.org/nl/question ... l&r=0&as=s

Eller
Berichten: 9
Lid geworden op: 1 Oktober 2013, 9:59
Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0

Re: geen toegang meer tot gepinde sites

Berichtdoor Eller » 3 Oktober 2013, 9:25

Die bovenste is de eenvoudigste, die probeer ik eerst. Lukt dat niet, dan zal ik de link eens gebruiken die je plaatste.
Komt er een oplossing dan meld ik dat terug.
Bedankt zover, Frederik

Eller
Berichten: 9
Lid geworden op: 1 Oktober 2013, 9:59
Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0

Re: geen toegang meer tot gepinde sites

Berichtdoor Eller » 4 Oktober 2013, 10:46

De fout blijkt te zitten in FF24.0
Mogelijk wordt deze bug nog gefixed, anders wachten tot V25, maar ik ga eerst de registeraanpassing proberen.
Even een verse ghost maken, want de meest recente is alweer meer dan een maand oud....

Gebruikersavatar
Frederik
Moderator
Berichten: 4273
Lid geworden op: 1 Juli 2004, 16:16
Locatie: Vriescheloo
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Re: geen toegang meer tot gepinde sites

Berichtdoor Frederik » 6 Oktober 2013, 13:09

Het probleem zit inderdaad in Firefox en met de vermelde register aanpassing direct verholpen.
Het is natuurlijk niet vreemd dat (ik) wij dat niet gelijk wisten. Zo lang er geen melding van komt 'bestaat' het probleem niet.
De functie van 'gepinde sites' gebruik ik nooit, dus heb ik het probleem maar gecreëerd door een gepinde website te maken en inderdaad verschijnt daarna de foutmelding. Ik heb de vermelde register aanpassing gedaan en daarna probleemloos de gepinde website kunnen activeren zonder foutmelding.

Startmenu > type: regedit > OK
Open HKEY_CLASSES_ROOT
Scroll naar beneden en klik FirefoxURL
Rechtermuisklik op FirefoxURL en selecteer Nieuw > klik Tekenreekswaarde
Verander "Nieuwe Waarde#1" in "URL Protocol" (zonder aanhalingstekens).
Alle vensters sluiten.
Gerepareerd!

Snap2.jpg
Je hebt niet voldoende permissies om de bijlagen te bekijken van dit bericht.

dartelaar16
Berichten: 1
Lid geworden op: 21 Oktober 2014, 18:28
Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.27 Safari/537.36

Re: geen toegang meer tot gepinde sites

Berichtdoor dartelaar16 » 21 Oktober 2014, 20:04

Ongelooflijk hartelijk dank voor het opstellen van deze thread: dus aan Eller en Frederik voor het vertalen van de oplossing gegeven in 't Engels door kstjohn.
Ik reageer vooral omdat ik een allicht voor iedereen belangrijke aanvulling heb als niet-informaticus: die tekenreeks URL Protocol blijkt wel heel veel gebruikt te worden. Waarschijnlijk omdat dezelfde werkwijzen voor gelijkaardige issues worden gevolgd. Creativiteit door elkaar te kopiëren.
Mijn probleem, Frederik en Eller, beschrijf ik hier in puntjes:
  • ik gebruik(te) wèl gepinde urls
  • in Chrome echter: ik had echter, zoals Eller met Firefox, gedeïnstalleerd en opnieuw geïnstalleerd
  • die gepinde urls heb ik al maanden in de AppLauncher van Chrome: zeg maar, een bewaarplaats voor urls waar je vaak heengaat: rechtsklikken op de AppLauncher in Windows 7 en je ziet ze. (één van de vele mogelijkheden naast bookmarks)
  • Maken? een url naar de AppLauncher slepen.
  • vanmorgen dacht ik "parallel door" en zocht in de HKEY_CLASSES_ROOT dus ChromeURL. Dat bestond/bestaat niet, maar wel vond ik er ChromeHTML en voegde daar URL Protocol toe
  • Bingo, de gepinde urls werkten weer; die nare identieke pop-up was weg. En dat nadat ik de door jullie vertelde weg ook had gevolgd nog voor ik jullie thread kende: standaardprogramma's zoeken en extensies koppelen zoals bijv. die "Standaardbrowser" ... maar ik koppelde ook .lnk aan Google Chrome !!
  • Gevolg: Mijn hele veld onder Start en alle snelkoppelingen waren onbereikbaar geworden... gelukkig sla je niet meer in paniek, omdat je dat herkent van crashes van jaren geleden: malwaremakers prutsen ook met die .lnk
  • Dus ging ik via Veilige modus naar Systeemherstel. Besluitje hierover: er staat daar bij die lange lijst extensies onder Standaardprogramma's (Windows 7), vrij vaak "onbekende toepassing": blijf er gewoon af als het niet hindert: het is zoals in CCleaner, onderdeel Register: nooit aanvinken als je 't register op fouten wil scannen "Ontbrekende gedeelde dll-bestanden" noch "Niet-gebruikte bestandsextensies". Maar het probleem was natuurlijk niet weg en toen vond ik jullie thread met de zoekwoorden: gepinde url.
  • Eind van mijn verhaal. 't Is maar dat nooit mag denken aan al die kostbare tijd die je verliest aan zulke futiliteiten: ze lijken al 10 jaar zware problemen en ze leiden tot procrastinatie. Zucht. Nogmaals hartelijk dank.
  • Tot slot: ik heb 3 bijlagen. Vanavond pas merkte ik via RegSeeker hoe vaak URL Protocol van belang is.
Je hebt niet voldoende permissies om de bijlagen te bekijken van dit bericht.


Terug naar “Suggesties en updates”