kwaliteit geluid Video

Nvu, Kompozer en Bluegriffon zijn open source (WYSIWYG) programma's waarmee je een website kunt maken en onderhouden (vergelijkbaar met FrontPage / Dreamweaver).
sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

kwaliteit geluid Video

Berichtdoor sers » 23 Mei 2015, 14:30

Goede middag mensen.
Ik heb onlangs een Video op onze site gezet die ik eerst in WindowsMoviemaker heb ge-edit. Ik heb er (rechtenvrij) geluid onder gezet.
Nu blijkt dat bij het afspelen het geluid hapert.
Het format is Mp4.
Is het beter om de video in een ander format te zetten (en zoja hoe doe ik dat) of wat doe ik verkeerd?
Alvast bedankt voor jullie antwoord!

Gebruikersavatar
nirwana
Beheerder
Berichten: 11221
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

Re: kwaliteit geluid Video

Berichtdoor nirwana » 23 Mei 2015, 18:33

Heb je de video naar jouw site ge-upload ?
Ik zou de video daarentegen bi Youtube uploaden (een andere video-hosting-site kan natuurlijk ook). Voordeel daarvan is dan dat zij de video hosten.

Vervolgens kun jij op jouw website de video "embedden". Bij een hosting-site als Youtube kun je daarvoor eenvoudig code opvragen. Daarmee krijg je dan de videospeler van Youtube erbij en zij verzorgen dan de encoding en het streamen van de video.

Dit kan bijvoorbeeld ook hier op het forum (met een speciale [youtube]-tag):

Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor sers » 24 Mei 2015, 9:10

Martijn
Bedankt voor je antwoord
Ik heb ondertussen die video in you tube ge-upload en via "delen" en "insluiten"
de desbetreffende code
<iframe width="420" height="315" src="https://www.youtube.com/embed/2agCKFO41D8?rel=0&amp;showinfo=0" frameborder="0" allowfullscreen></iframe>
in een testpagina gezet.
Ik krijg de melding (met afbeelding van you tube) met de text ""er is een fout opgetreden Javascript kan niet worden uitgevoerd""
Wat doe ik fout?


sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor sers » 24 Mei 2015, 9:10

Alvast bedankt voor je antwoord!

sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor sers » 24 Mei 2015, 9:49

Sry Martijn.
Ik denk dat ik het gevonden heb.
Het is een Java instelling in Chrome vanaf een bepaalde versie
chrome://flags/#enable-npapi
Ik heb dus NPAPI ingeschakeld.
Hoop dat het veilig is. Wat vindt u er van?

mvg

sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor sers » 24 Mei 2015, 9:54


sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor sers » 26 Mei 2015, 9:16

1 klein vraagje over YouTube:
Aan het einde van mijn geuploaded video krijg je suggesties te zien van andere video's
Wat moet ik doen om die suggestie niet te laten zien?

Gebruikersavatar
nirwana
Beheerder
Berichten: 11221
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (iPhone; CPU iPhone OS 6_1_6 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10B500 Safari/8536.25

Re: kwaliteit geluid Video

Berichtdoor nirwana » 26 Mei 2015, 19:19

Die suggesties op het eind kun je wegwerken door deze (Engelse) instructies te volgen:
http://illuminea.com/remove-related-vid ... ube-video/
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

Gebruikersavatar
nirwana
Beheerder
Berichten: 11221
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (iPhone; CPU iPhone OS 6_1_6 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10B500 Safari/8536.25

Re: kwaliteit geluid Video

Berichtdoor nirwana » 26 Mei 2015, 19:22

Overigens zou ik denken dat Chrome ook wel zonder Java, Flash en dergelijke plug-ins een Youtube-video moet kunnen afspelen.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

Gebruikersavatar
nirwana
Beheerder
Berichten: 11221
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor nirwana » 26 Mei 2015, 20:43

Als ik jouw video-code hier op het forum invoer dan krijg ik de melding dat die video inmiddels is verwijderd.
Misschien is dat ook de oorzaak van de foutmelding die jij kreeg ?

Overigens vraag ik me nog steeds af waarom de Youtube embed-code in jouw geval tot Java en NPAPI leidt.
Ik zou verwachten dat daarmee Youtube de video aan Chrome via een HTML5-speler zou aanbieden.

Als Google Chrome aangeeft dat je iets alleen met speciale opstart-vlaggen voor elkaar krijgt, dan kan dat volgens mij 2 dingen betekenen:
1) de code die je gebruikt is verouderd (maar via een speciale constructie kun je die nog een tijdje blijven gebruiken, totdat je over bent naar de nieuwere code
2) de code die je gebruikt is nog nieuw in Chrome en heeft nog een experimentele status

In jouw geval zou ik eerder voor optie 1 gaan. Ik zou dan zoeken naar een methode waarbij je geen NPAPI expliciet hoeft in te schakelen.
Misschien ben jij wel zo handig om die optie in de browser in te schakelen, maar toekomstige bezoekers van jouw site ga je vast geen instructies voorschotelen over hoe zij in Google Chrome via NPAPI jouw video's kunnen bekijken. Of als zij toevallig met Mozilla Firefox of met Microsoft IE aankomen dat je dan weer andere instructies aanbiedt. Doorgaans is dat ook nog weer afhankelijk van welke versie van de betreffende browser men gebruikt, want Google Chrome ondersteunt al de HTML5-player en Firefox ook (afhankelijk van welk besturingssysteem je gebruikt).

De embed-code van Youtube moet jou dit soort verschillen juist uit handen nemen, zodat Youtube dit wel voor jou gaat uitzoeken.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor sers » 26 Mei 2015, 22:24

Beste Martijn,
Ik heb NPAPI weer uitgeschakeld.
Vraag het me aub niet maar nu doet alles het weer zoals het zou moeten
Ik heb de video eerst gedeleted (moest nog wat bij) en toen weer geuploaded.
Het stelt allemaal niets voor (Ik beslis niet wat er wel of niet op de site komt) maar het ging mij meer om het technische aspect.
Volgens mij is alles nu ok (http://www.hvhetslot.nl/videoplantjesdag2015.shtml)
Nogmaals bedankt voor de moeite
mvg

Gebruikersavatar
nirwana
Beheerder
Berichten: 11221
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

Re: kwaliteit geluid Video

Berichtdoor nirwana » 26 Mei 2015, 23:57

Hoi,

De video werkt bij mij zonder problemen in Firefox, Chrome en IE.
Dat lijkt mij een prima resultaat.

Ik neem aan dat dit nu beter werkt dan toen je zelf het MP4-bestand op de site had staan (en het scheelt ook nog diskruimte op de server).
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

sers
Berichten: 61
Lid geworden op: 15 November 2011, 13:29
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Re: kwaliteit geluid Video

Berichtdoor sers » 27 Mei 2015, 9:16

Martijn,

idd VEEL beter en minder ruimte.
Nogmaals hartelijk dank voor uw hulp
m.v.g.
Jacques


Terug naar “Nvu/Kompozer/Bluegriffon”