Linux -> KTorrent->downloads->Error

Plaats hier berichten die in eerste instantie niets te maken hebben met Mozilla, de activiteiten van ProMozilla en ThunderbirdNL of met de artikelen op MozBrowser.
Gebruikersavatar
BlackDog42
Berichten: 24
Lid geworden op: 13 April 2009, 11:18
Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Linux -> KTorrent->downloads->Error

Berichtdoor BlackDog42 » 4 Mei 2011, 15:07

Hallo iedereen,

Nu ik over ben gegaan op Linux-ubuntu, en diverse problemen met het gebruik ervan heb opgelost, kom ik nu iets tegen waar ik niet zo 1,2,3 een oplossing voor kan vinden.
Om muziek te downloaden gebruik ik KTorrent als sluis, wat vergelijkbaar is met UTorrent, of BitTorrent op Windows OS.
Het downloaden van muziek gaat perfect, doch........... films downloaden lukt dus helemaal niet.
Als ik via IsoHunt een film selecteer om te downloaden verschijnt er een Error-notification op de pagina van KTorrent met de volgende melding:
An error occurred while loading the torrent /tmp/[isoHunt] Cube[1997]DvDrip[Eng]-BugZ.torrent:
Parse Error
The torrent is probably corrupt or is not a valid torrent file.


Is er iemand die mij kan vertellen wat deze melding inhoudt, en/of een suggestie aandragen?

Ik heb gekeken naar een setting voor downloadbare herkenbare files, maar kan niets vinden om eventueel aan te passen.

Is dit nu een Linux probleem in het algemeen, of een setting probleem van de KTorrent?

p.s. Deze info heb ik gevonden op internet, maar kan ik hier iets mee en zo ja.......hoe werkt het (installeren van b.v. KTorrent 4.1.*)

Package: ktorrent
Version: 4.0.5-3
Severity: important

Lately I found that many torrent files cannot be opened by ktorrent.

ktorrent says:
An error occurred while loading the torrent something.torrent:
Parse Error
The torrent is probably corrupt or is not a valid torrent file.

Vuze can open the same file.

-- System Information:
Debian Release: wheezy/sid
APT prefers testing
APT policy: (990, 'testing'), (500, 'oldstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages ktorrent depends on:
ii kdebase-runtime 4:4.4.5-1 runtime components from the offici
ii ktorrent-data 4.0.5-3 KTorrent data and other architectu
ii libc6 2.11.2-11 Embedded GNU C Library: Shared lib
ii libgcc1 1:4.5.2-4 GCC support library
ii libgeoip1 1.4.7~beta10+dfsg-4 A non-DNS IP-to-country resolver l
ii libkdecore5 4:4.4.5-3 the KDE Platform Core Library
ii libkdeui5 4:4.4.5-3 the KDE Platform User Interface Li
ii libkdnssd4 4:4.4.5-3 the DNS-SD Protocol Library for th
ii libkhtml5 4:4.4.5-3 the KHTML Web Content Rendering En
ii libkio5 4:4.4.5-3 the Network-enabled File Managemen
ii libkjsapi4 4:4.4.5-3 the KJS API Library for the KDE De
ii libknotifyconfig4 4:4.4.5-3 library for configuring KDE Notifi
ii libkparts4 4:4.4.5-3 the Framework for the KDE Platform
ii libkrosscore4 4:4.4.5-3 the Kross Core Library
ii libktorrent-l10n 1.0.5-2 localization files for the KTorren
ii libktorrent2 1.0.5-2 the KTorrent library for C++ / Qt
ii libkutils4 4:4.4.5-3 various utility classes for the KD
ii libkworkspace4 4:4.4.5-8 library for the kdebase workspace
ii libphonon4 4:4.6.0really4.4.2-1 the core library of the Phonon mul
ii libqt4-dbus 4:4.7.2-3 Qt 4 D-Bus module
ii libqt4-network 4:4.7.2-3 Qt 4 network module
ii libqt4-qt3support 4:4.7.2-3 Qt 3 compatibility library for Qt
ii libqt4-script 4:4.7.2-3 Qt 4 script module
ii libqt4-svg 4:4.7.2-3 Qt 4 SVG module
ii libqt4-xml 4:4.7.2-3 Qt 4 XML module
ii libqtcore4 4:4.7.2-3 Qt 4 core module
ii libqtgui4 4:4.7.2-3 Qt 4 GUI module
ii libsolid4 4:4.4.5-3 Solid Library for KDE Platform
ii libsolidcontrol4 4:4.4.5-8 library for Solid based network ma
ii libstdc++6 4.5.2-4 The GNU Standard C++ Library v3
ii libsyndication4 4:4.4.5-2 parser library for RSS and Atom fe
ii libtag1c2a 1.6.3-1 TagLib Audio Meta-Data Library
ii phonon 4:4.6.0really4.4.2-1 metapackage for the Phonon multime

ktorrent recommends no packages.

Versions of packages ktorrent suggests:
pn plasma-widget-ktorrent <none> (no description available)

-- no debconf information

--
To UNSUBSCRIBE, email to debian-bugs-dist-REQU...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org

Gebruikersavatar
Frederik
Moderator
Berichten: 4273
Lid geworden op: 1 Juli 2004, 16:16
Locatie: Vriescheloo
Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Re: Linux -> KTorrent->downloads->Error

Berichtdoor Frederik » 4 Mei 2011, 18:27

Is er een andere Torrent client beschikbaar voor Ubuntu ?

http://ktorrent.pwsp.net/forum/viewtopic.php?f=2&t=3998

Gebruikersavatar
nirwana
Beheerder
Berichten: 11229
Lid geworden op: 19 September 2003, 5:09
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Re: Linux -> KTorrent->downloads->Error

Berichtdoor nirwana » 4 Mei 2011, 20:01

Frederik schreef:Is er een andere Torrent client beschikbaar voor Ubuntu ?
Voor zover ik weet is Transmission de torrrent-client die bij Ubuntu wordt geleverd.

Disclaimertje: Hoewel ik Bittorrent een prima protocol vind, vind ik het ook jammer dat het nogal eens wordt misbruikt voor het downloaden van auteursrechtelijk beschermde content. Zo vind ik het protocol bijvoorbeeld prima werken voor het downloaden van een ISO-image van een Linux-distributie. Dat ontlast de servers van de makers en/of hun mirrors weer een beetje, aangezien op deze manier iedereen een stukje van met elkaar deelt. Wat dat betreft voorzie ik nog een goede toekomst voor het downloaden van content via p2p-technologie. Alleen moeten de protocollen dan niet voor die tijd al aan hun eigen succes ten onder gaan.

PS: ik wil hier geen ellenlange discussie ontketenen over of het downloaden van auteursrechtelijk beschermd materiaal al dan niet geoorloofd is. Dat is eenzelfde discussie als welke besturingssysteem het beste zou zijn: alle systemen hebben voor- en tegenstanders en daar gaan we voorlopig niet uit komen ;-)
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

Gebruikersavatar
adri
Moderator
Berichten: 11531
Lid geworden op: 5 Maart 2005, 14:00
Locatie: Diessen
Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

Re: Linux -> KTorrent->downloads->Error

Berichtdoor adri » 15 Mei 2011, 21:27

KTorrent op eigen houtje gaan upgraden lijkt me niet verstandig (is immers een onderdeel van KDE, dan moet je dat allemaal gaan upgraden, zou ik niet doen...). Ik heb zelf geen ervaring met die foutmelding, maar ja, ik maak ook weinig gebruik van KTorrent.

Wat in je post al staat is een alternatief: Vuze!
Hier staat info over hoe je dat installeert op Ubuntu: http://ubuntuforums.org/showthread.php?t=995327
Afbeelding


Terug naar “De vergaarbak”