Foutje in Firefox Update - Extenties en Thema's

Hier kun je je opmerkingen over de Nederlandse Firefox-vertaling kwijt.
Gebruikersavatar
Tonnes
Berichten: 814
Lid geworden op: 20 November 2004, 21:40

Berichtdoor Tonnes » 2 December 2004, 18:24

Anne schreef:\u (de character reference equivalent daarvan is &#x, niet &#) is hexadecimaal, niet decimaal.

Klopt. Ik vermoed dan ook dat die 8217 is achtergebleven uit een eerdere foute &# -notatie.

Verder geloof ik dat in de genoemde gevallen beter voor \u0027 gekozen kan worden aangezien 27h/39d officiëel het teken voor de apostrof is, en niet het acute accent B4h/180d, dat eigenlijk voor klemtonen wordt gebruikt.

En om het verhaal compleet te maken: 8217d (2019h) staat voor een rechts aanhalingsteken, dat wéér iets anders is. Voor het goede dienen daarom ook alle voorkomens van 8217d in de &# -codes vervangen te worden door 0039d. Bij testen werkt dit naar behoren en het ziet er ook netter uit.

Gebruikersavatar
Peter Koopman
Berichten: 32
Lid geworden op: 1 December 2004, 12:39

Berichtdoor Peter Koopman » 3 December 2004, 11:40

Tonnes schreef:Verder geloof ik dat in de genoemde gevallen beter voor \u0027 gekozen kan worden aangezien 27h/39d officiëel het teken voor de apostrof is, en niet het acute accent B4h/180d, dat eigenlijk voor klemtonen wordt gebruikt.


Klopt. Ik ben in mijn voorstel uitgegaan van een teken dat visueel zoveel mogelijk op teken 8217 lijkt en in de basis ascii-tabel voorkomt. Maar apostrof is inderdaad correcter. Of het er ook netter uitziet is natuurlijk een kwestie van smaak. ;)

Gebruikersavatar
nirwana
Beheerder
Berichten: 11180
Lid geworden op: 19 September 2003, 5:09

Berichtdoor nirwana » 3 December 2004, 12:00

Ik neem aan dat dit soort fouten wordt gecorrigeerd en binnenkort als nightly-taalpakket weer te downloaden is ? Of hoe verloopt dat proces ? Na iedere wijziging die in de vertaling wordt doorgevoerd komt er een nieuwe nightly build van ?
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over GIMP, Mozilla, OpenOffice.org / LibreOffice, opensource en Windows 10 ]

Anne
Berichten: 462
Lid geworden op: 22 September 2004, 11:24

Berichtdoor Anne » 3 December 2004, 12:14

Momenteel zijn ze bezig met alles te "verneuken" (ook wel avairy-landing genoemd) en ik gok dat alle regressions e.d. daarvan eerst gefix moeten worden. Daarna zal denk ik l10n voor Firefox 1.1 op de plank komen en zullen er ook l10n nightlies verschijnen. Die werken uiteraard niet meer met Firefox 1.0, maar alleen met nightly builds voor Firefox 1.1.
weblog | werkt mee aan mozilla.org, Mozilla Europe, developer.mozilla.org en een beetje aan addons.mozilla.org

Gebruikersavatar
Peter Koopman
Berichten: 32
Lid geworden op: 1 December 2004, 12:39

Berichtdoor Peter Koopman » 7 Maart 2005, 9:31

Ik zit naar de 1.0.1 versie te kijken. :? Maar dit probleem zit er nog altijd in... Is er dan niemand die dit kan aanpassen?

Het kost mij met een goede teksteditor ongeveer 3 minuten.

Misschien begrijp ik de hierarchie niet, maar een kleine aanpassing als deze moet toch mogelijk zijn?

Anne
Berichten: 462
Lid geworden op: 22 September 2004, 11:24

Berichtdoor Anne » 7 Maart 2005, 12:18

Niet mogelijk. Triviale veranderingen worden juist geweerd omdat er dingen mis zouden kunnen gaan. Het zal opgelost zijn in versie 1.1. Hopelijk gebruiken we dan helemaal geen espacing mechanismes meer maar direct het karakter.
weblog | werkt mee aan mozilla.org, Mozilla Europe, developer.mozilla.org en een beetje aan addons.mozilla.org

Gebruikersavatar
Peter Koopman
Berichten: 32
Lid geworden op: 1 December 2004, 12:39

Berichtdoor Peter Koopman » 7 Maart 2005, 13:39

Anne schreef:Triviale veranderingen worden juist geweerd omdat er dingen mis zouden kunnen gaan.


Dat is ook weer waar natuurlijk. Hoe vaak ik al niet een heel triviale wijziging heb gedaan, die tien programma´s verderop een fout veroorzaakte. :wink:

pkoopmanpk
Berichten: 1
Lid geworden op: 25 September 2005, 21:53

Re: Foutje in Firefox Update - Extenties en Thema's

Berichtdoor pkoopmanpk » 25 September 2005, 22:02

Peter Koopman schreef:Klein foutje in het onderstaande scherm. Raar blokje in het woord Thema's.


Nu is het bijna een jaar geleden dat ik deze fout gemeld heb. Bij elke XPI update die je download staat het pontificaal in je scherm te schitteren.

Gaat dit ooit opgelost worden? Of staat dit straks in versie twee gewoon nog steeds?

Als dit wat cynisch overkomt dan spijt me dat... Maar om heel eerlijk te zijn, zo voel ik me op het moment een beetje.

Het is een fout die ik binnen 3 minuten kon oplossen. Het risico op verstoringen op andere plaatsen is, volgens mij, bijna nihil. Maar toch is er niemand in het vertalersteam die het gaat aanpassen.

Maar misschien begrijp ik jullie werkwijze niet en is er een hele goede reden voor.

Gebruikersavatar
Gert-Paul
Berichten: 2417
Lid geworden op: 4 Maart 2004, 17:48

Re: Foutje in Firefox Update - Extenties en Thema's

Berichtdoor Gert-Paul » 25 September 2005, 22:15

pkoopmanpk schreef:
Peter Koopman schreef:Klein foutje in het onderstaande scherm. Raar blokje in het woord Thema's.


Nu is het bijna een jaar geleden dat ik deze fout gemeld heb. Bij elke XPI update die je download staat het pontificaal in je scherm te schitteren.

Gaat dit ooit opgelost worden? Of staat dit straks in versie twee gewoon nog steeds?

Mischien is het vervelend voor je dat deze fout er nog inzit, maar wij als vertaalteam kunnen hier niets aan doen. Het is niet toegestaan om veranderingen aan een vertaling te maken bij een beveiligingsupdate. Simpelweg omdat het veel meer werk kost om alles weer helemaal goed te testen.

Als lange tijd kun je de vertaalde Firefox nightlys downloaden waarin deze fout verbeterd is, hoewel het updatesysteem natuurlijk helemaal op de schop gegaan is en ik me afvraag of dit scherm er nog inzit. Deze melding zal waarschijnlijk dus niet meer terugkomen, maar dit is een keer correct verbeterd.

Ik wil je dus vragen in de toekomst eerst in de nieuwste versies te testen, hoewel jij het niet kon weten dat er geen veranderingen in de vertaling van Firefox 1.0.x toegestaan worden.
Laatst gewijzigd door Gert-Paul op 25 September 2005, 22:16, 1 keer totaal gewijzigd.

Anne
Berichten: 462
Lid geworden op: 22 September 2004, 11:24

Berichtdoor Anne » 25 September 2005, 22:15

Over wat voor updates heb je het? Het vertaalteam kan niks wijzigen aan security gerelateerde updates.
weblog | werkt mee aan mozilla.org, Mozilla Europe, developer.mozilla.org en een beetje aan addons.mozilla.org

Gebruikersavatar
Peter Koopman
Berichten: 32
Lid geworden op: 1 December 2004, 12:39

Berichtdoor Peter Koopman » 26 September 2005, 7:48

Gert-Paul schreef:Ik wil je dus vragen in de toekomst eerst in de nieuwste versies te testen, hoewel jij het niet kon weten dat er geen veranderingen in de vertaling van Firefox 1.0.x toegestaan worden.


Anne schreef:Over wat voor updates heb je het? Het vertaalteam kan niks wijzigen aan security gerelateerde updates.


Dit waren inderdaad de vragen waarmee ik zat.

Ik heb gisteren versie 1.0.7 geïnstalleerd. Voor mij was het absoluut onduidelijk waarom zo'n relatief kleine fout die visueel zo aanwezig is niet opgelost wordt.

Maar met deze antwoorden is het helemaal duidelijk.

Misschien moet ik de volgende keer eerst een nachtje slapen voor ik in een licht geïrriteerde staat naar de pen grijp. :wink:


Terug naar “Nederlandse Firefox-vertaling”